Rename .closest()

Rename .closest()

I can't count the number of StackOverflow questions I've seen where they misused .closest(), thinking it would find the nearest sibling, cousin, etc. element that matches a selector. I think I've even seen it in places where .find() is what they want. This expectation matches the normal meaning of the function name, since closeness is not usually restricted to a particular direction.

I suggest that it be renamed to something like .closestParent(), to make it clearer that it only searches through the parents, not everywhere in the DOM.

Maybe the name is too entrenched, but that didn't stop you from deprecating .bind() in favor of .on().