At the last jQuery conference someone asked if we could remove the need to call the base widget destroy method from each plugin's destroy method. This should be very easy to accomplish by just having the base destroy method call _destroy and then changing all plugins' destroy methods to _destroy. This would introduce another API change, but like all the other API changes coming with the new widget factory this is an extremely simple upgrade path. Also, nothing should break if a plugin isn't updated. In addition to this request, John pointed out that when destroying a method because of the element being removed from the DOM, a lot of the undoing is unnecessary. He suggested adding a second, trimmed down version of destroy specifically to be used on remove. We would need to decide on a name for this method. Any objections to either of these?