Hi! Love jQuery.

The function $.inArray just caused me alot of confusion. This was mainly because of the name.

I propose a name change to $.indexOf, and the creation of a "real" inArray function, which returns true/false if element is in array.

See the conversation in the comments at the docs.

My second proposal is an optimization of $.indexOf. If a native indexOf exist, this function should replace $.indexOf on the first call.