jquery.simple.tree.js - jquery 1.4.2 : when drag shows JS error

jquery.simple.tree.js - jquery 1.4.2 : when drag shows JS error

Dear friends,

I have a jquery Tree  program. I got from the net written by Mauro. here we can drag and sort the node.
To run this program, we need 2 JS file.

1) jquery.simple.tree.js
2) Jquery file.

For Jquery I used latest version. 1.4.2.
When I ran the program, tree working fine, But when I  start to drag, it dragged but displayed a JS error "Invalid Argument". I am using IE8. My project work only in IE8.

So I tried it with Jquery previous version, in IE8,  the drag working with Jquery 1.3.2.

But I should use Jquery 1.4.2 (Latest version).

The program is a attached herewith.
Please check it and can you help me how I can use it with Jquery 1.4.2 and jquery.simple.tree.js.

It is not a big program, only basic things are there. You can run with out any server. Please check it.
and help me combinationhow i can run this program with out JS error with a jquery.simple.tree.js  and  jquery 1.4.2 in IE8.

I think if it works on IE 8 with JQurey 1.4.2, lot of people can work with this and thanks for the script to original author Mauro.