Question on Widget Event Names

Question on Widget Event Names


I'm have a question about how to name events for callbacks. I know the
standard is to use simple names for callbacks, like:
start, drag, stop
However, my widget has many methods that have corresponding events,
because these actions can also be triggered though interface element.
Here are a few examples...
Method - Event
============
open - onopen
close - onclose
hide - onhide
show - onshow
So is it OK to use the 'on' syntax for events, like "onopen"? If not,
how would you suggest handling methods and callbacks that *should* use
the same terminology?
/Kevin