Rename bind/unbind?

Rename bind/unbind?


With the inclusion of Function.prototype.bind in ECMAscript 5, I'd
like to open discussion around possibly modifying the API around bind/
unbinding events. I feel changing jQuery would help keep it's API
cleaner. For example, the following seems dirty and will cause
unnecessary confusion:
jQuery.bind('click', someFunction.bind(this));
Maybe listen/unlisten, watch/unwatch, or something similar would be
better.