Selectmenu doesn't open when inside a Popup widget in Android 2.3

Selectmenu doesn't open when inside a Popup widget in Android 2.3

This had been a issue since the old versions of jQM and still exists.
The selectmenu doesn't seem to open (natively), when inside a element (div..etc.) with the position set to absolute.
I tried using the selectmenu inside a Popup widget... and it didn't work.
I even tried using the DateBox widget inside a dialog page with the combobox enabled (to choose the year/month).... and didn't work.

I recently tested jQM 1.2.0 Final selectmenu in Android 2.3 & 4.1 (inside a popup widget), and it seems to work fine in Android 4.1, but not in 2.3.

I even debugged using to take a look at the css... and I think I saw the problem.
When I hover the mouse on top of the select element, it highlights the actual position of the element in the mobile, so the position of the highlight was way on top of the selectmenu (forgot to mention, this popup was opened after scrolling a bit down).

I tried to open the popup without scrolling, and the funny thing is... it opens; but with a little effort tapping here and there around the selectmenu. So I think the problem is the position of the actual select element, due to that it doesn't respond to our tap.

Any ideas on how to fix this or even a temporary solution to get the selectmenu (inside a popup) working??

Thanks in advance =).

JQ Version 1.8.2
JQM Version 1.2.0 Final
PhoneGap Version 2.1.0 (Cordova)
Android Version 2.3.3 / 2.3.6 (HTC Desire Z / Huawei Ascend G300 U8815)