Just some thoughts that come to mind looking over this...
Sean started working on an effects.text.js that implements the following "effects" functions:
textExplode, textConverge
backspace, type
disintegrate, build
blockFadeOut, blockFadeIn
They work beautifully so far, but I think we need to try to make this more like the other effects, and use "show" and "hide" modes of the same animation. It seems other effects tend to use the "hiding" operation i.e. "explode, drop, fold, blind"
Also - a little curious about the naming of the effects:
$("div").show("text-explode") vs $("div").show("textExplode")
Should all the text effects be prefixed with "text"?
Anyone have any better names for these effects?
There is a "demos" page that shows the current text effects in that branch.